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Preface 

This workshop contains an assortment of examples on parameters.  
 
What is the purpose of this functionality?  
Suppose that a SCIA Engineer user handles nearly every day with the same type of 
structure.  
Only the dimensions, cross-sections, height, number of spans, … differs in the different 
projects. For this, the option ‘Parameters’ can be used.  
Every type  -as mentioned above- can be parameterized. 
The parameters are fully editable and when changed they may lead to a very 
straightforward modification of the calculated model. 
What’s more, a model defined by means of parameters can be saved as a template. 
When opened, the user is first asked to fill in the table with all the parameters present in 
the model. This may be effectively used for creation of simple "programs" for e.g. 
calculation of continuous beam, simple frame, etc. 
 
The user has to create the structure only once. Then he/she has to define the 
parameters and save the structure as template. In the future, he/she just fills in the table 
with a few parameters and can immediately proceed to calculation and evaluation of 
results. 
This leads to a huge reduction of the working hours and will be more effective.  
 
Above this, this workshop contains also some extra’s which can help the user to 
become more effective in working with SCIA Engineer:  
- XML: SCIA Engineer supports exporting and importing to/of this format.  
- ODA: One dialog application 
- Batch optimizer: The user can give a range of values to a parameter and the 

solution is also a range of results.  
- User blocks: A project can be saved as a user block. Afterwards, this block can be 

imported  in another project.  
- Project templates: As mentioned before, the user can make a standard project 

which can be used for all the other projects.  
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Beam on two supports 

 
 

A beam manufactured of C30/37 according to the EC-EN is supported on two ends.  
We will input parameters for the length and the cross-section dimensions.  

 
 

 
 

 
 
 
 

 Project data:  - Construction type: Frame XZ 
                                         -  Project level advanced 

 

 Input support:  
 
 

 
Method  

 

 After activating the functionality parameters, you will see the function 
 
 
 
 

 The parameters get following properties with the values: 
- Length L: 10 m 
- Width B: 300 mm 
- Height H: 500 mm 
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 Next, go to:  
 

                                                                                                   
 
Here the template tabs are made 

 

 
 
Remark: the introduction of the picture will be explained later.  
 
 

 Subsequently you can use a new function:  
 

Here the values of the various parameters can be adapted. 
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 The various parameters has to be attributed now to the cross-section and the length 
of the beam. 

 
 Length beam: X-coordinate of node K2:  
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 Width & height profile:  
 

 
 
 

 Changing a parameter:  
 
The value of the length L is adjusted of 10m to 20m. 
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If you use ‘Store users- default settings’, you can make various compositions which 
you can load afterwards: 
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Cross-sections 

 
The same example will be used to explain the type of parameters for cross-sections.  
For this ‘Cross-sections.esa’ can be used.  
First of all the parameters for graphical cross-sections are explained. Next, the 
parameter for the type of cross-section will be shown.  

 

General cross-section 

 If the user decides to work with a graphical cross-section, the method of 
parameterizing is different from that of standard cross-sections.  

 First of all parameters has to be created for the height en width of the cross-section.  
 

 
 

 Next, the polygon can be introduced and after this, the parameters can be attributed 
to the Y and Z coordinates:  
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The difference with the parameters of a profile from a library is that here the parameters 
can be made in the cross-section editor itself.  
 

 Above this, if the user wants to adapt these parameters, two parameters has to be 
created in ‘Tools > Parameters’.  
Here, we can create the same parameters H1 and B1: 
 

 
 
Note:  

____________________________________________________________________ 
It’s very important that you give a good description to your parameters. On that way, it 
simplifies afterwards the input and the adaptation of the parameters.  

____________________________________________________________________ 
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 These values can now be attributed to the properties of the profile:  

 
 
 

 To change these values, we can make a new tab in the ‘Parameters template 
settings’ and this will appear now in the ‘Template dialogue’:  
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Type of Cross-sections 

 
In SCIA Engineer it’s also possible to parameterize libraries. Examples here are: 
Materials, cross-sections, reinforcement, subsoils,… 
In this topic, we will explain it for the type of cross-sections.  
The other library types can be handled with the same principle.  

 
Again, this will be explained by means of example ‘Cross-sections.esa’.  
 

 Three cross-sections are inserted in the project:  
CS1: RECT(400;400) 
CS2: Graphical cross-section 
CS3: CIRC (400) 
 

 We define a ‘master’ cross-section. This cross-section is fictive and will be the 
parameter. For this, we copy arbitrarily CS1 and we call it ‘Master’.  

 For this master cross-section, the option ‘Selector Switch’ has to be checked and an 
Alternative profile can be choosen now:  

 Creation of the parameter:  
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Without this option ‘selector switch’, we cannot use the parameter for the cross-section 
type.  

 Go to ‘Tools > Parameters’ and the following parameter can be created: 
 

 
 
Type: Library 
Library: Cross-sections 
Value: Here the fictive ‘master’ cross-section can be input.  
Alternative: One of the 3 alternatives can be choosen. This alternative will be the 
default profile.  
Select Alternatives: The 3 alternatives can be inserted here 
 

 Attribute this parameter to the cross-section type of the beam. Pay attention: The 
master profile becomes the parameter. But the content of this master will change 
after choosing another alternative:  
 

 
 

 After creating a new tab in ‘Tools > Parameters Template settings’, it appeared in the 
dialogue box of the ‘Template Dialogue’. And again, this box can be used to change 
the cross-section type:  
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And this results into:  
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Catalogue block 

 

In this example a catalogue block will be inserted. After the introduction of it, it will be 
parametrized.  

 

 Project data:  - Construction type: Frame XYZ 
                            -  Project level : advanced 

 

 Go to ‘Structure >  Advanced input > Catalogue blocks’.   

 

The first block in the menu ‘Frame 2D’ is choosen. We keep the standard 
configuration:  

 

 
 

 
 

 

 Input support:  
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Method: 
 
 

 First of all, the parameters will be created. Go to ‘Tools > Parameters’:  
 

                                                                                                 
 

 

 The following properties are parameterized with a begin value of: 
1. Span  L: 10 m 
2. Height H1: 5 m 
3. Height H2: 1,5 m 
4. Htot: H1 + H2 
5. Middle: L/2 
6. Rigidity support: 5*10

-6
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 When closing this window, the following question appears: 
 

 
 
 

Click ‘Yes’ if formulae were used so they can be checked. 
 

 Now the parameters are attributed to the various geometry-properties. 
 

 Subsequently a line grid can be made: 
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 The line grid can also obtain a parameter to adjust the view. This is possible 
through a binary parameter with a Boolean value (yes/no). 
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Plate on subsoil 

 
 

 
 
 

  

 Project data:  - Construction type: General XYZ 
                                   - Project level advanced 

 

 Input support:  

 
 

 Input subregion:  

 
 

 

 Load cases:  
- LC1: Selfweight 
- LC2: Permanent plane load q [kN/m^2] 
- LC3: Free surface load on projected area: q [kN/m^2]  
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Method 

 

 The following parameters are applied: 
- Length L: 7 m 
- Width B: 3 m 
- Permanent plane load: 5 kN/m^2 
- Free plane load : 2 kN/m^2 
- Thickness plate d: 200 mm 
- Thickness subregion d1: 400 mm 

 

 Adjusting the value of the free plane load: 
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Cellular beam 

 

 

 

 
 

 
 

  

 Project data:  - Construction type: General XYZ 
                                   -  Project level advanced  
 

 Input opening through:  ‘Structure > 1D member > Modificator > Opening’.  
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Method 

 

 The following parameters are attributed to the member: 
 

 
 

- Height profile h: 300 mm 
- Width profile b: 200 mm 
- Thickness web d: 12 mm 
- Thickness flange d1: 20 mm 
- fillet d2: 12 mm 
- Length member L: 6 m 
- Diameter bore hole D: 150 mm 
- Position first bore hole x: 0,15 
- Number of bore holes a:  6 

 

 Next, these items are attributed to the structure.  

 Subsequently the template settings and template dialog is made. 
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Beam with practical reinforcement 

 
 

It’s also possible to parameterize the reinforcement. This will be shown in following example.  
 

 
 

 Project data:  
- Construction type: Frame XZ 
- Project level advanced 
 

  Input through: 

  
 
 

 Load cases:  
                       - LC1: Selfweight 
                       - LC2: Variable load: q  [kN/m] 
 

  Input practical reinforcement:  
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Method 
 

 Input of the following parameters with begin value: 
 
- Height profile H: 400 mm 
- Width profile B: 400 mm 
- Span L1: 3m 
- Span L2: 3m 
- Total span Ltot: L1 + L2 
- Variable line load Q: 15 kN/m 
- Reinforcement diameter above db: 12 mm 
- Reinforcement diameter below do: 16 mm 
- Reinforcement diameter stirrups dstirrup: 8 mm 
Remark: the reinforcement diameters can only be parameterized when using the practical 
reinforcement. 
- Stirrup distance a: 0,3 m 

 
 

 

 Group parameters through: 
 

  
   

 
In the dialogue box of the parameter template settings, pictures can be attributed from the 
gallery:           
 

 
 
  You get the best resolution if you choose the following properties during saving:  

- .wmf 
- 550 x 550 
 

 Check through Template dialogue 
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 Afterwards, the entire project can be saved as a template.  
This by doing the following: save in the directory ‘Esa xx > Templates’ 

 
 

 The project can now be opened as a template and adjusted: 

 
 

 
 
 
 

 After opening this template, a dialog box with the entered parameters appears. If 
desired, particular properties can be adjusted here. 

 



Advanced Training - Parameters 

28 
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Ground-level 
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 Project data:  
- Construction type: General XYZ 
- Project level advanced 
 

 Functionalities :  
- Subsoil 

             - Soil loads 
             - Parameters 

 

 Input support through:  

 
 

 

 Input geological profile and subsoil through:  
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 Load cases:                 -  Selfweight 
- Water pressure 
- Soil pressure 

 
 

Method 
 

 Parameter: 
 - Height bore hole profile h: -1 m, restriction between 0 m and -4 m 
 

 
 

 Test of input data through: 
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Layers 

 
In this example the number of spans will be varied. This can be done by means of a 
truc. The basic principle is: every beam belongs to a layer.  

Above this a layer has two properties: Activity and Structural type (also Drawing model).  

The principle is as follows:  
A layer that is not active will not be displayed on the screen.  
A layer that has the structural type will not be calculated.  
 
This means that if you put a beam into a layer that is both non-active as in the structural 
model, it will not be visible and above this, it will not be calculated.  
 
On that way we can make parameters for the properties of the layers.   

 
 

 Project data:  
- Construction type: Frame XZ 
- Project level advanced  

 

 Functionalities - Parameters 
                                                                                                                 
 

 

 Input support through:   
 
 

Method 
 

 The number of members is varied. This is done by means of Parameterizing the 
activity and the type of model (analysis/structural)  

 

 Input parameters: 
 

1. Number of members N: 3 
Remark:  
The maximal number of beams is the number of beams that had been introduced in 
the project.  
 

2. Activity of the layers :  Boolean 
- L1: formula   N>=1  
- L2: formula   N>=2 
- L3: formula   N>=3 
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3. Model type of the layers: Boolean 
- C1: formula   not (L1) 
- C2: formula   not (L2) 
- C3: formula   not (L3) 

 
Example:  
 
N=2: 
 L1 and L2: true, L3 is false 
 C1 and C2: false, C3 is true 
This means that Layer 1 and 2 are visible and not in the structural model.  
Layer 3 will not be displayed and will be in the drawing model (not in the analysis 
model).  
 
 

 

 
                                                                                                
 

 Grouping the parameters through: Tools > Parameters template settings 
 

 Subsequently a parameter is attributed to the various layers: 
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 Variation number of member through the template dialogue 
 

 Use the activity toggle 

  
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This gives as result:  
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Steel hall 

 

 

 

In this example, the number of spans will be parameterized. The same principle with the 
layers as in the previous example will be used.  

 

 Project data:  
- Construction type: Frame XYZ 
- Project level advanced 

 

 Functionalities - Parameters 
                                                                                                                 

 

 Input support through:  Support > nodal support.  
 

                                                                                                                 

 Input catalogue block with parameters H1, H2 and L 
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Method 

 

 The number of frames is varied, ranging from 1 up to and including 7, through the 
binary parameters for the model type and the activity. 

 

 Applying the following parameters: 
o Height H1: 5 m 
o Height H2: 1,5 m 
o Total Height Htot: H1 + H2 
o Length L: 10 m 
o Number of frames NS: 7 
o Frame distance S: 5 m 
o Frame distance 1 t/m 5 (S1/5): S*1 ... S*5 
o Total frame distance S6: S*(NS-1) 
o Activity layers B1 t/m B7: NS >=1 .. NS>=7 
o Construction model layers A1 t/m A7: not (B1) … not (B7) 
 
 
At which the following parameter types are used: 
 
o Height, length and frame distance : length 
o Number of frames: integer 
o Activity and type of model layers: boolean 
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 Now the parameters can be attributed to the properties of the model: 
 

- Layers 
 

 
 
- Geometry properties of the catalogue block 
- Coordinate Y of the nodes of the model:  parameter frame distance 
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Plate with ribs 

 
Two types of parameterized plate with ribs are shown here. The previous principle of 
the properties of the layers is used here.  
 

Plate with ribs_1.esa 

 

 
 

 In the first case the number of ribs is dependent on the width of the plate. The offset 
of the ribs and the distance between several ribs remains the same in each case.  

 

 To obtain this, we divide the plate into several parts. The number of the parts is equal 
to the maximal number of ribs. 

 

 In this case we the maximal number of ribs is 6. 
             So, a parameter N with type ‘integer’ is made with standard value 6. 

 

 Other parameters are:  
A1...A6:  Boolean  
               Formula: N>=1…6 
 
C1…C6: Boolean 

                   Formula: not(A1…A6) 
 

 Afterwards, these parameters can be attributed to the properties of the 6 created 
layers: 
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The plate with the connected rib can now be input in the respective layer.  
In the ‘view parameters for all’ , the colour can be set on ‘colour by layer’.  
This is practical to verify if each rib is in the correct layer: 
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 After creating a group in the ‘parameters template settings’, the number of ribs can be 
adapted in the Template dialogue: 
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Plate with ribs_2.esa 

 
In this case, the offset between the outer ribs and the end of the plate remain constant.  
The distance between the inner ribs is always regular.  
 
This is shown in the understanding example.  
 
Originally, a plate with 5 ribs is created. Afterwards, the ribs are input in layers and the 
x-coordinates are parameterized.  
 

 First of al the parameter for the number of ribs is created:  
This can be an integer value between the range of 2 to 5. 
 

 
 

 The offset coordinates of the outer ribs are:  
- x for the first ribs 
- B- x for the last rib, with B the parameter for the width of the plate 

 

 The 3 inner ribs get the following coordinates: 
- x2 = x+((B-2x)/(N-1)) 
- x3 = x2+((B-2x)/(N-1)) 
- x4 = x3+((B-2x)/(N-1)) 

 

 As in the previous examples, parameters A1..A5 and C1..C5 are created for the 
properties of the layers 

 To finish this, the ribs are attributed to the correct layers.  
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 When changing the number N in the template dialogue, we get the following results:  

 

 N = 2 

 

 

 N = 3 

 

 

 N = 4 

 

 N = 5 
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Tubular plates 

 

 
 
 
 

 

 Project data:  
- Construction type: General XYZ 
- Project level advanced 

 

 Functionalities – Parameters 

 Input channels as ribs: Plate rib 
 
 

Method 

 The principle is as follows:  
The plate is divided into different subplates. The reason for this is if the plate will 
shorten, also a rib will disappear. By making different little plates, this can be solved.  

 Making the parameters that determine the geometry properties of the plate and rib:  
- width profile b: 1480 mm 
- height profile h: 1100 mm 
- height upper flange h1: 250 mm 
- height lower flange h2: 160 mm 
- thickness web t: 140 mm 
- thickness plate d: =h1 
- length partial panel: =b 
- angle of fillet plate alpha: 30° 
- total length plate Ltot: 12 m 
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 These parameters are attributed to the channel 
 

 
 
 

 Input of 1 plate (as an element of the whole plate) 

 Input of the plate rib with effective width b 
 

 
 

 Use of dummy members, e.g. circular profile with diameter 5mm so the rib and 
member can be connected  by a common node. 
Without these dummy beams, the ribs will not follow the plate after changing the 
dimensions of the plate.  

 Connect nodes/edges to members!  
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 Input other plates through “more copies”:  
 

 
 
 

 
 
 

 An angle alpha of 30° is entered as parameter. With this, the x- and y-coordinates of 
the vertices of the partial plates can be entered: 
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Example:  
 
Partial plate 6: 
 
                                           
 

- x-coordinate x6: = b*6 
- y-coordinate y6a: tg (alpha) * x6 
- y-coordinate y6b: tg(alpha)*x6+ Ltot 

 

 
 
 
 
This way, an inclined plate is obtained.              
 

 Adjusting the number of partial plates/ribs: 
 

- Parameter for the number of parts: N (< = 10) 
- Parameter L1..10:  They determine the activity of the various layers 

Vb. L6: boolean with formula N>=6 
- Parameter C1..10:  they determine the type of model of the various layers 

Vb. C6: boolean with formula not(L6) 
 
 

 Making the different parameter template and adjusting the number of parts to e.g. 6 
through the template dialog: 
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 Analysis model: 
 

 
 

 
 Structural model 
 
 

 
 

 
 
 

                                                  
 
 
 
 
 
 
 
 

 Input support: 
- parameter R: point stiffness 450 MN/m  
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Hollow core slab 

A practical use of parameters is in the case of hollow core slabs.  
In this example several functionalities are applied: 

- prestress 

- building stages 

- TDA 

- Parameters 

 

 

 Project data:  
- Construction type: Frame XZ 
- Project level advanced 

 
 

 Functionalities 
–   Parameters 
– Concrete: fire resistance 
– Prestress: 

                                          Advanced 
                                                            Hollow core slab 

 Model: Construction stages 

 Span: 6.2 m 

 Material type: concrete C25/30         
 

 The hollow core slab is entered by means of a dwg 

 

 

 

 

 

 



     Advanced Training - Parameters 
 
 

51 
 

Method 

 

1. Entering a cross-section 

 

The outline and the opening are selected alternately, after which they can be imported 
through 'import selection'. 

 

 

 

2. Inserting the prestressed tendons 

 

Subsequently the prestressed tendons are entered: 

Go to the concrete menu > Prestress – strand pattern:  

2 regions are now made for the bore hole pattern. 
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The initial stress of the prestressed tendons is 1250 Mpa. 

 

 

 

3. Inserting the supports 

- point load on node, at begin and end node of the member 

- point load on member: on0,07 and 6,13 m 

- point load on member: on 0,8 and 5,4 m 

 

4. Making the load cases 

 

 

 

 

- Selfweight member 

- Prestress 1250 Mpa 

- Stage 2: empty (permanent) 

- Stage 3: empty (permanent) 

- Stage 4: line load on member 0,6 kN/m (permanent) 
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- Stage 5: line load on member 1,2 kN/m (permanent) 

- Stage 6: line load on member 1,2 kN/m (variable – long term) 

- Stage 7: empty (permanent) 

 

 

5. Inserting the construction stages 

 

 

 

 

 

 

Stage 1 
Prestress and selfweight of the member 
 
Load cases: presstress + selfweight 
Time: day 1 
Relative  humidity: 100% 

 
 

 
 
Stage 2 
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Transport 
 

Load cases: empty 
Time: day 1,1 

Relative humidity: 100% 
 

 
 
Stage 3 
Storage 
 
Load cases: empty 2 
Time: day 1,2 
Relative humidity: 70% 
 

 
Stage 4 
In situ, placing the plate 
 
Load cases: q wall 0,6 kN/m 
Time: day 28 
Relative humidity: 70% 

 

 
 
 
Stage 5 
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Casting of the coating 
 

Load cases: 1.2 kN/m 
Time: day 50 
Relative humidity: 70% 
 

 

 

 

 

 

Stage 6 
Service 
 
Load cases: long termVar 1.2 kN/m  will be used as long term load. Here it is 
important to pay attention to the duration of the load case, sc 'long'.   
 
Time: day 100 

          Relative humidity: 70% 
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Stage 7 

After 50 years 
 
Loads 
Load cases: empty3 
Time: day 18000 

         Relative humidity: 70% 

 

 

 

6. Inserting the parameters 

 

- Length hollow core slab:  

Type: length 

Evaluation: value: 5,25 m 

 

- Height hollow core slab: 

Type: cross-section length 

Evaluation: value: 150 mm 

 

- Location support on member: 

Type: length 
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Evaluation: formula: resp. Length member – 0,07 and length member – 0,8  

 

- Parameters general cross-section: 

Type: cross-section length 

Evaluation: value 

(examples: width to first opening, width opening, width between the openings,...) 

 

- Initial stress:  

       Type: stress 

       Evaluation: 1200 Mpa 

 

 

- Anchorage length:  

Type: length 

Value: 1m 
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- Line loads: 
 
Type: line load 
Value:  
- wall: -0,5 kN/m 
- casting coating: -1,75 kN/m 
- long term var: -1,75 kN/m 

 
- Time of prestressing 

 
Type: time (history) 
Value: 1 day 
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- T2 up to and including T7:  
 
Type: time (history) 
Value: 1,1; 1,2; 28; 50; 100; 18000 
 
- Relative humidity 
 
Type: relative humidity: 

       Value: 70 and 100% 
 
 
- Cross-section type 
 
Type: library 
 
Method: make a ‘master’ cross-section (copy of the original cross-section) and use the 
option ‘possible alternative’. 
 
Subsequently it can be used with parameters as follows: 
 

 
 
 
- Strand pattern 
 
Type: library 
 
Method: idem as the cross-section type. Make various strand patterns and copy a type as 
a master case. 
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Analogous possibilities for the type of library are: materials, stressing beds, bore hole 
patterns, … 
 
Other possibilities to parameterize: 
Moment of casting, Moment of releasing the casting 
 
 
7. Making openings in de hollow core slab 
 
Two openings are made, of which a number of values are parameterized, sc: 
 
-   delta x: 

      Type: length 
Value: 1m 
 
- Width, length and depth opening: 
Type: cross-section length 
Value: 500 and 150 mm 
 
- x_offset: 
Type: cross-section length 
Formula: -width/2 
 
- x_hole: 

      Type: length 
Value: 2,1 m 
 
- n_hole: 

      Type: integer 
Value: 2 
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8. Using the template dialog 
 

Subsequently these parameters can be divided and the template dialog can be used: 
 

 

 
 

9.  Different number of spans 
 

Now the number of spans can be adjusted by means of copying the hollow core slab 
and to divide it into layers. For example: 3 elements. 
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Subsequently the following parameters can be used: 
 

- N: number of spans 
Type: integer 
Value: 3 
 
- Activities of the various layers: 
 
Type: boolean 
Evaluation: formula 
    A1: N>=1 
    A2: N>=2 
    A3: N>=3 
 
- Construction type of the various layers: 
 

       Type: boolean 
Evaluation: formula 
    C1: not(A1) 
    C2: not(A2) 

                 C3: not(A3) 
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XML 

 
SCIA Engineer allows for the exchange of data with third-party applications through the  
popular and powerful XML format. Moreover, XML format can be used to develop tailor-
made applications that use SCIA Engineer as a "hidden" engine working on the 
background and performing calculations of company-specific problems. 
 
The XML file editor is very similar to the Document of SCIA Engineer. The principle is 
that the user defines tables describing individual entities of the SCIA Engineer projects 
and there order. This table-form can be easily previewed (it is in fact identical to the 
standard SCIA Engineer document). When ready, the final XML file contents can be 
transformed into the real XML format through the export function. 
 
 
 
 

 Take example 8 again: steel frame.esa 
 

Through  
 
 
 

 
 
 
 

 
 

 

mk:@MSITStore:C:/Program%20Files/SCIA/Engineer2008/ESA.chm::/html/Introduction_to_document.htm


     Advanced Training - Parameters 
 
 

65 
 

 
 Export to XML: 

 

 
 

 Adjusting the parameter L: 10  20 
Remark:  
For this purpose, it’s necessary that the XML-document is opened in a text-file, for 
example: notepad.  
 

 
 

 Regenerate the project through ‘File > Update > XML file'. You will see that the 
structure has been changed now.  
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ODA 

 
 
Oda is the abbreviation of ‘One dialog application’. It’s also called the SCIA engineer 
Template.  
 
It can be used for following type of projects:  
 

 
 
 
 
In this workshop the options ‘Parametric project’ and ‘Batch optimizer’ will be used.  
The Batch optimizer will be explained in the next example.  
 
The main principle of ODA is as follows:  

- In SCIA Engineer a project is made, eventually with parameters and with document, 
and saved as a template.   

- After this, SCIA Engineer has to be closed. It’s not possible to open the same project 
in ODA and in SCIA Engineer at the same time.  

- Now, ODA can be opened and the user has to choose the type of project.  
- In the most used case ‘parametric project’, the user can change the value of the 

parameters and the result is a document with all the added tables.  
- This is shown in the following model.  
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 Project data:  

Construction type: General XYZ 
Project level advanced 
Material: concrete C20/25 

 

 Functionalities – Parameters 
 

 Load cases: 
- Selfweight 
- Variable line load: 1 kN/m 
 

 Combinations: UGT and BGT 

 Document input: 
- Nodes 
- Load cases 
- Combinations 
- Internal forces: My 
- Deformations: uz 
 

 Parameters: 
- Diameter cross-section: 200 mm 
- Thickness cross-section: 5mm 
 

 

Method 

 

 Save this project, e.g. Oda.Esa, in the folder ‘Templates’ and close (if this is not 
performed, a conflict will arise when opening ODA). 

 then open the program SCIA ODA:  
 

 
 
 
 

 The following dialog box appears: 
 



Advanced Training - Parameters 

68 
 

 
 
Choose the option ‘Parametric project’.  

 

 The following dialogue box appears: 
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 Now the various steps can be re-run and possibly adjusted: 
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 Finally the following document is obtained in ODA after an automatic calculation:  
 

 
 
 
Note:  
______________________________________________________________________ 
So, it’s not possible to adapt the geometry on the graphical screen like we do in SCIA 
Engineer.  
In ODA, only the inserted parameters can be adapted.  
It’s also not possible to add new tables in the document. ODA uses the document from 
the template.  
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Batch optimizer  

The batch optimizer is a special function of ODA. First of all a parametric project is 
made in SCIA Engineer. 
 
Then an input and output file has to be made in XML. Subsequently they can be read in 
ODA. 
A begin and end value of the parameter can be filled in and an iteration step to be 
performed. The results are the values of the desired output parameter. 
 
Example:  
 
A beam on two supports is created in SCIA Engineer. The line load is parameterized.  
In ODA the moment My will be asked for a certain range of this parameter.  
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 Project data:  - Construction type: Frame XYZ 
                                         -  Project level advanced 

 

 Input support:  
 
 
 

Method 
 

 The line load is parameterized with a begin value of –5 kN/m 
 

 Subsequently go to ‘Tools > XML IO document’ and export an input and output file:  
 
Input file: 
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Output file: 
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 This project can now be opened in ODA. For this, you choose the option ‘Batch 
optimizer’. 

 
 

 
 
 
 

 Subsequently a dialog box appears in which the Esa project and both XML files have 
to be collected: 
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 If an optimisation was used in the Esa project, it can be taken into account here by 
selecting the option ‘optimisation calculation’.  
 

 
 

You can ask for the results for a number of  values of the parameter. Here the parameter ‘line 
load on member’ can be used. A begin value of -5 and an end value of -10 can be taken with 
an iteration step 1.  
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The values of the output XML file that have to be evaluated, can be marked. The values 
for My_max and My_min are checked.  
 

 
 

Possibly constant values and formulae can be inserted. They will be taken into account 
in the result table. 
 
Finally you can go to the results, where a calculation is performed for the various line 
loads. This is performed in various iteration steps, which are executed independently 
from each other. 
 
The result is as follows: 
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Example 14: User blocks & ProjectTemplates 

 

User blocks 

SCIA Engineer enables the user to make a library of his/her projects that are used over 
and over again. These projects may be at any time included into a newly created project 
or appended to an earlier created and currently edited project. 
The projects in this user-created library are called User blocks and the library is called 
User block library. 
 
We take example 8 again: Steel frame.esa 
 
Save as user block: 
‘File > Save as ‘ and then save in the file userblocks.  
 
You can find it in: 

 

 

 
 

 Make a new project, e.g. in general XYZ 

 Open the Structure menu : 
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The following dialog boxes appear: 
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 Insert another user block 
- with NS = 3 
- frame distance = 8 and NS = 4 
- length L = 15 and NS = 3 

 

 Here you can get the following example: 
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Project templates 

 

In practice it may quite often happen that some elements are used in every project. For 
example, material types, cross-sections, predefined loads, and even parts of a structure may 
be the same in various projects. Therefore, it would be efficient, if the user could store the 
repetitious elements aside and load them quickly into every new project. 

In SCIA Engineer this may be achieved via templates. Generally speaking, a template is an 
ordinary project that holds required information and is saved in a special way. 

Let’s take example 8 again: Steel frame.esa 

 
 Save as template: ‘File > Save as' in the folder: 
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 Close example 8 and open a new project. Go to the tab ‘User templates’.  
 

 
 
 
 

 When opening this template, also here a dialog box appears with possible 
parameters that can be adjusted: 
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General parameterizing 

 
If you doubt if a certain property can be parameterized or not, it is advisable to create as 
many types of parameters as possible that can possibly be the required parameter. 

 

Type of parameters: 
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Possible formulae: 
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Possible operators in SCIA Engineer: 

 

 
 
Example of a formula: 
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